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c h a p t e r 1 Get Started

Control4® Composer Media Edition is the software you use to add and 
scan media and create playlists on the Control4 system. It is a Windows 
XP-based PC program that has a drag-and-drop interface.

The center of the Control4 system is the Media Controller or other 
Control4 controller hardware, such as Home Theater Controller. 

The controller hardware communicates with Control4 and third-party 
products to enable home automation and interaction of individual 
devices.

NOTE: When the term “controller hardware” is referenced in this 
documentation, it refers to any Control4 product that contains the 
Director component, such as Media Controller or Home Theater 
Controller.

Topics covered in this chapter:

“Software and Network Requirements”

“Install Composer Media Edition Software” on page 3

“Launch Composer Media Edition Software” on page 4
chapter 1:  Get Started 1
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Software and Network Requirements
This product requires that your system is functioning correctly before 
attempting to use the software. Please see your authorized Control4 
dealer if this product does not work as documented because it indicates 
that the Conrol4 system is not set up properly.

Software and network requirements for using Composer Media Edition:

Control4 controller hardware (such as Media Controller)

PC Software and Hardware
Composer Media Edition (launches Microsoft .NET 1.1 web install)
Microsoft Windows XP and Service Pack 2 (Home or Professional)
500 Mhz processor or higher
256 MB RAM
80 MB Hard Disk space
Video card and monitor supporting resolution of 1024x768 or higher
Keyboard
Mouse

TCP/IP-based home network (DSL/Cable Modem, Control4 
Secure Gateway, router, or switch) to connect PC to controller 
hardware
Internet Connection (broadband required for retrieving cover art 
and media information) 
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Install Composer Media Edition Software
To install Composer Media Edition software:
1. Launch the Composer Media Edition installation and follow the on-screen instructions. You 

might be asked for a registration key. 

2. When prompted to update, follow the on-screen instructions to update to the latest version of 
Composer Media Edition.
The software version and the drivers might have been updated since the CD or Web download 
was created. It is recommended that you always choose to update.

TIP: You have three options for updating Composer, including: 
 
“Update Composer Media Edition from Help Menu” on page 32 
“Update Composer Media Edition from Windows Start Menu” on page 32 
“Update Composer Media Edition by Running Installation” on page 32
chapter 1:  Get Started 3
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Launch Composer Media Edition Software
When you launch Composer Media Edition software, you must connect 
to Director on your home network. 

To launch Composer Media Edition Software:
1. From the desktop, double-click the Composer icon.

2. At the Composer startup screen, choose Director on Local Network.

The Virtual Director and Remote Director 
shown on the Startup screen are not available 
with the Composer Media Edition.

3. From the Director dialog that appears, choose the Director’s address of the physical hardware 
(such as Media Controller) you are setting up.

TIP: If the Director’s address does not appear immediately, click the Refresh 
button. If it still does not appear, contact your authorized Control4 dealer.
4 Composer Media Edition User Guide
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4. Click Connect.

Composer is opened to the main Composer Media Edition interface
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C h a p t e r 2 Set up Media and Playlists

To view and select the media from the Navigator devices, including Wireless Touch Screen, 
On-screen, Mini Touch Screen, and System Remote Control, you first need to add and scan 
the media to the controller hardware (such as Media Controller).
With the MP3 files you have added and scanned, you can create playlists of MP3 files saved 
to the controller hardware’s hard drive or the external hard drive.

TIP: This product requires that your system is functioning correctly 
before using this software. For example, if a DISC Changer is not 
appearing on the left pane, there is not a DISC Changer in the system 
to add media to it. You will need to contact your authorized Control4 
dealer to add a device not appearing to the Control4 system.

Please see your authorized Control4 dealer if the product does not work properly.
Topics covered in this chapter:

“Now that you have completed “Set up Media” continue to “Test System by Playing Media 
on Navigator Device” on page 131.”
“Set up Media on DISC Changer” on page 9
“Set up Media for Broadcast Television Channels” on page 15
“Set up Media for Broadcast Stations” on page 17
“Create Playlist” on page 21
“Refresh Navigators” on page 23

Set up Media on a Controller
When you set up media on a controller with a storage space for media, the controller has a 
built-in Digital Audio Player.
Digital Audio is the “cloud” in the controller that provides the digital audio streaming. Each 
source device that can provide an audio stream, whether it is a CD changer plugged into the 
analog inputs on a Control4 Speaker Point or a Control4 controller, such as a Media Controller, 
can provide audio to the Digital Audio servers. Each must have a connection to the Digital 
 Chapter 2:  Set up Media and Playlists 7
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Audio Cloud. When configuring these connections under the Connections view, there is 
always an open connection to the Digital Audio Cloud for each Digital Audio Server or Digital 
Audio client. Therefore, you will potentially see many connections to the Digital Audio Cloud 
depending on the hardware configured in the project.

To add and scan available Digital Audio Player media by doing the following:

1. Within the controller pane (right pane), click Add. 

TIP: If you get a dialog box that states you cannot add, make 
sure you have identified your Media Controller or controller 
hardware in the Connections view > Network tab.

2. Browse to directory of music files to add.
Once the files are added, the scan automatically starts. After a few moments the media is 
scanned and you will see a list of albums appear. You might see the On-screen navigator 
update during this process.
8 Composer Media Edition User Guide
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3. Refresh Navigator devices. See “Refresh Navigators” on page 23.
The media is now selectable for viewing within the Navigator devices, including Wireless 
Touch Screen, On-screen, Mini Touch Screen, and System Remote Control.

Set up Media on DISC Changer 
When setting up a DISC Changer, you can add and scan media according to the options 
available on your DISC Changer. Adding and scanning populates the media information to the 
Media Database, which allows you to view the media from your Navigator devices, including 
Wireless Touch Screen, On-screen, Mini Touch Screen, and System Remote Control.
In the Media pane (left pane), when you highlight DISC Changer, if options are available on 
your DISC Changer, you will see following active buttons:

Scan — Allows you to add and scan media located on your DISC Changer and add them 
to the Media Database (recommended if available).
Search — Allows you to search for media titles located on your DISC Changer and add 
them to the Media Database.
New DVD or New CD — Allows you to add new DVDs and CDs to the Media Database.

The following sections show how to add media to the Media Database using these options.
 Chapter 2:  Set up Media and Playlists 9
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To scan media on DISC Changer to Media Database:
1. Highlight DISC Changer in the Media pane (left pane). 
2. In the DISC Changer pane (right pane), click Scan. 

The scan results appear. After you Refresh Navigators you are ready to play music. See 
“Refresh Navigators” on page 23. 

To search media on DISC Changer to add to Media Database:
1. Highlight Media Controller in the Media pane (left pane). 
2. In the DISC Changer pane (right pane), click Search.

The search dialog appears.
3. Type the DVD name into the blank field. 

Example: “A Beautiful Mind”
The possible DVD title matches from the web database appears in the Search Results 
window.

4. Use the scroll bar if necessary to find the appropriate DVD title.
10 Composer Media Edition User Guide
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5. Highlight the appropriate DVD title and drag it directly over the empty line item and highlight it. 

6. Click Finished.
7. Repeat these steps for the DVDs/CDs in the DISC Changer you want to add to the Media 

Database.
8. Refresh Navigator devices. See “Refresh Navigators” on page 23.

The media you have added is now selectable for viewing within the Navigator devices, 
including Wireless Touch Screen, On-screen, Mini Touch Screen, and System Remote 
Control. 
 Chapter 2:  Set up Media and Playlists 11
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To add and search using New DVD or New CD options:
1. Highlight DISC Changer in the Media pane (left pane). 
2. Highlight the empty field for the New DVD and New CD buttons to appear. 
3. Click either New DVD or New CD as appropriate. 

The New Movie or New Album dialog appears.
4. In the Title field, enter the DVD you want to play.

Example: A Beautiful Mind
5. Click Search.

6. When the Search dialog appears, use the scroll bar if necessary to find the appropriate cover 
art and click to highlight it.
You can change the search criteria and search again if necessary. The possible matches from 
the web database appear in the Search Results window.

7. Click Next.
12 Composer Media Edition User Guide
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You can choose which information to import and edit any associated information before adding 
to the Media Database.

8. Click Finished.
9. Click OK.

10.Refresh Navigator devices. See “Refresh Navigators” on page 23.
This particular DVD is now selectable for viewing within the Navigator devices, including 
Wireless Touch Screen, On-screen, Mini Touch Screen, and System Remote Control.
 Chapter 2:  Set up Media and Playlists 13
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Autoscan Media Within Composer
This is a new documentation topic. The benefits of running a DISC Changer with bi-directional 
communications (RS-232), such as Sony CX777ES, is that you can scan your DVDs/CDs 
stored in the disc changer to identify, index, and automatically apply cover art information. 
You can configure your system within Composer or Composer Media Edition to automatically 
scan media or to manually scan media when the Scan button is selected within Composer or 
Composer Media Edition for the associated DISC changer. The default is to scan media 
manually. 

When the Auto Scan Enabled option is selected from the device properties page, the 
automatic scan of disc(s) is available only when you add a new disc to an empty slot or a disc 
is removed. Whenever a disc is added to an empty slot or a disc is removed, the DISC 
Changer will automatically recognize the change. The Navigator devices will automatically 
update with the change. The DISC Changer recognizes the changes in its slot when its door 
closes to perform the automatic scan. The Autoscan feature does not detect when a disc is 
replaced or swapped.

NOTE: If a DVD/CD is scanned and the media is not recognized, it 
will be titled as “unknown.” You can edit the information about the 
DVD/CD and manually provide this information from either Composer 
or the Navigation devices. If this DVD/CD is then changed to a 
different slot, the system will apply this same information.  
 
Related Topics: 
“Edit Media Information within Composer” on page 23 
“See also Navigation device user documentation for editing media 
cover art using one of the Navigation devices.
14 Composer Media Edition User Guide
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Autoscan Added Media
To autoscan added media:

1. From the Project Tree, click the Sony CX 777ES DISC Changer added to the project.
The device properties page appears.

2. Ensure that a check is in the Auto Scan Enabled box.

3. Open the DISC changer drive and change the existing DVD/CD.
4. The autoscan begins automatically when the DISC Changer door closes and the information 

for the added DVD/CD is automatically available from the navigation devices.

Set up Media for Broadcast Television Channels
Set up Media for Broadcast Television Channels
1. Highlight UHF/VHF or other broadcast media type.
2. Click Search.
3. When the dialog appears, note that your zip code appears automatically in the field.
4. Click Search and use the pull-down menu to select Local Broadcast Listings.

The available channels are populated to the Search Results.
5. Click the boxes to select the desired channels that you want to appear on the Navigator 

devices, including Wireless Touch Screen, On-screen, Mini Touch Screen, and System 
Remote Control.
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6. Click OK.

The selected stations populate in the UHF/VHF pane.

7. Refresh Navigator devices. See “Refresh Navigators” on page 23.
The media is now selectable for viewing within the Navigator devices, including Wireless 
Touch Screen, On-screen, Mini Touch Screen, and System Remote Control. 
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Set up Media for Broadcast Stations
Set up Media for Broadcast Radio Stations:
1. Click Search. 
2. When the dialog appears, note that your zip code appears automatically in the field.
3. Click Search and use the pull-down menu to select AM Broadcast Stations or FM 

Broadcast Stations.
The available stations are populated to the Search Results window.

4. Click the boxes to select desired stations that you want to appear on the Navigator devices, 
including Wireless Touch Screen, On-screen, Mini Touch Screen, and System Remote 
Control. 

5. Click OK.
 Chapter 2:  Set up Media and Playlists 17
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The selected stations populate in the FM Radio pane.

6. Refresh Navigator devices. See “Refresh Navigators” on page 23.
7. Repeat steps 1-7 for each radio (AM, FM, XM) you want to set up. Each of these must be set 

up separately.
The media is now selectable for viewing within the Navigator devices, including Wireless 
Touch Screen, On-screen, Mini Touch Screen, and System Remote Control.

Use External Storage Devices
You can access digital music from an external storage device on your Control4 system. 
External storage devices include USB flash drives or USB external hard drives or a PC’s drive 
located on the home network.
You need to set up according to the external storage device and networked file storage as 
described in this section. External storage devices must have media stored in unprotected 
MP3 format.

NOTE: When you remove the external drive (network, USB, etc., the 
music is no longer available. In order to access the music again, 
return the external storage device and from the File menu, select 
Refresh Navigators.

To attach and scan external storage devices using a USB connection:

1. If you need to power on the external storage device, turn it on.
2. Use the documentation provided with your controller hardware to attach the external hard 

drive using the USB port.
18 Composer Media Edition User Guide
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3. Once you physically connect the external storage device, you need to scan the music residing 
on the external device connected to the controller hardware (such as Media Controller) to 
make it available on the Control4 system.

4. Highlight the controller to which the external device is connected. 
5. Click Scan.

You can add media from the external storage device when connected to the Media Controller. 
However, it is recommended that you connect your external drive directly to the PC where you 
want to copy media.
When scanning, the media appears as it is located on the controller hardware.

To access and scan network storage devices:

1. Use the documentation provided with your operating system to create a shared network drive.
Example: Using Windows XP to make a local C:/ Drive directory available on the network, 
right-click the folder and select Sharing and Security. Select the Share this folder button.

2. Configure the username, password, and workgroup (or domain) for the network file share.
This information varies between types, contact your system administrator if you need help with 
this information. 

3. Highlight the Network File Storage object (left pane). 
 Chapter 2:  Set up Media and Playlists 19

mber 20, 2005 Composer Media Edition 1.2.3 Release Control4 1.02



Add an Audio or Audio/Video Switch to Control4 System

De
4. Click Add or Scan.

Add an Audio or Audio/Video Switch to Control4 
System

To highlight a few Audio/Video Switch products, the following audio or audio/video switch 
drivers are now available for use in the Control4 system:
Control4 Audio Switch
Anthem MCA 50 (Relay)
B&K AV2600 (Relay)
Knox RS16x15 HB
Knox RS16x15 HB AO
Knox RS16x15 HB VO
Knox RS4x4 HB
Knox RS8x8 HB
Knox MediaFlex16
Marantz MM-9000 (IR)
McIntosh MC2102 (Relay)
Meridan 558.2 (Relay)
Parasound HCA-1500A (Relay)
Pioneer PRO-R05U (IR)
Primare Systems A30.3 MKII (Relay)
Rotel RB-993 (Relay)
Sony TA-N220 (IR)

As more are continually added, you can access the AV switch drivers from within the System 
Design view in the Items pane, select Search tab > Device Type: A/V Switch or Audio 
Switch > Manufacturer: All Manufacturers. Use the Driver Wizard for additional support for 
your audio or audio video switch.
20 Composer Media Edition User Guide
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To add an Audio or Audio/Video Switch:

1. Set up the audio or audio/video switch and any associated hardware.
2. Add the audio or audio/video switch to your project from within the System Design view, under 

the Items pane, select the Search tab > Device Type: Audio Switch or A/V Switch > 
Manufacturer: All manufacturers. 
Example: To add the applicable Knox A/V switch (RS-232) driver, within the System Design 
view, under the Items pane, select the Search tab > Device Type: A/V Switch > 
Manufacturer: All manufacturers.

3. When the A/V Switch object is added to the project tree, highlight the object to view the device 
properties for that object to make configuration changes if applicable. 
Example: The Knox A/V Switch has no properties to modify, but other switches have 
properties, such as the Control4 Audio Switch.

4. Make any necessary network or control/AV connections as necessary for your configuration.
5. Modify any room connection bindings as needed for your configuration.

Create Playlist
To create playlist:
1. From the Media menu, select New Playlist.

2. A New playlist will appear that you can rename immediately or later you can right-click and 
select Edit to change the name.
Example: Change New to Frank’s Playlist.

3. Ensure that you have scanned your media in the Digital Audio player.
The Playlists are designed exclusively for streaming media within Digital Audio. Playlists are 
not intended to include CDs/DVDs or broadcast channels or stations.

4. Highlight Media Controller.
 Chapter 2:  Set up Media and Playlists 21
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5. Drag and drop any albums or individual songs you want to add to the playlist to Frank’s 
Playlist.

6. After you have added the albums, highlight the playlist to delete songs you do not want in your 
playlist by right-clicking the song and selecting Delete. You can select more than one by 
holding down the shift key.

TIP: To remove individual song, right-click Delete. To remove 
multiple songs, press shift and highlight items, then right click 
Delete.

Now you are able to edit and play your playlist using the Navigator devices, including Wireless 
Touch Screen, On-screen, Mini Touch Screen, and System Remote Control. 
22 Composer Media Edition User Guide
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Refresh Navigators
1. In case your Navigators did not automatically refresh, choose File > Refresh Navigators.

TIP: When you add or scan media, you need to use the Refresh 
Navigators option to update the media views on all Navigator 
devices.

2. Now that you have completed “Set up Media” continue to “Test System by Playing Media on 
Navigator Device” on page 131.

Edit Media Information within Composer
You can edit the media information for “Unknown” DVDs or CDs using the Composer 
Professional or Media Editions. See the instructions that follow. You can also edit the media 
information within the Navigator devices, such as On-Screen Navigator, Touch Screen, or Mini 
Touch Screen.

Edit CD Information within Composer
To edit a CDs information within Composer:

3. Double-click the device you would like to edit a CD on, such as CD, DISC Changer, Media 
Controller or Digital Audio.
 Chapter 2:  Set up Media and Playlists 23
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4. Click the Edit button or double-click the album under Album Title.

5. To edit and enter any changes, click in the boxes under Name, Artist, Label or Genre under 
the Album tab. Under Tracks and Notes tabs, view and edit Track Titles and Notes. When 
finished click OK. (Click Cancel to exit screen.)
24 Composer Media Edition User Guide
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6. Click one of the Search buttons beside Name or Artist to search the database for similar 
entries. 

7. To select a search result, select the album Title and double-click or click Next. At the next 
screen you can view and edit the information of the album, including Name, Artist/Composer, 
Label, Genre, Year, Art, and Notes.
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8. Make changes as desired and click Finished. If you would like to return to previous screens 
to make changes, click Back.
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Edit DVD Information Within Composer
To edit a DVDs information within Composer: 

1. Choose a movie under DISC Changer or DVD.
2. Click the Edit button or double-click the title under Discs.

3. Under the Movie tab, edit the Title, Director, Studio, Genre, Run Time, Release date and 
Rating as desired on this screen under the Movie tab. Under the Cast and Synopsis tab click 
in Cast and Synopsis fields to make desired changes.
 Chapter 2:  Set up Media and Playlists 27

mber 20, 2005 Composer Media Edition 1.2.3 Release Control4 1.02



Edit Media Information within Composer

De
4. Click Search under the Movie tab to search the database for other DVDs.
5. Double-click the desired DVD and edit as desired according to the steps above.
6. When you are done with your changes, click Finished.
28 Composer Media Edition User Guide

cember 20, 2005 Composer Media Edition 1.2.3 Release Control4 1.02



Clear Media List

Dece
C h a p t e r 3 Other Composer Tasks

This chapter provides steps for performing tasks using Composer.

Clear Media List
To clear media list:

1. Highlight the device that you want to clear the Media List.

Example: Digital Audio

2. From the Media menu, select Clear Media List.
This removes the information including the title art and information 
from the Media Database. This option does not remove the actual 
media files.
Chapter 3:  Other Composer Tasks 29
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Connect to Director on Local Network
To connect to a Director on your home network:

1. Start Composer: 

From the desktop, double-click the Composer icon.

Or go to the Composer Startup screen that is displayed, 
choose Director on Local Network.

NOTE: Within Composer, to connect to a Director on your home 
network, from the File menu, select Connect to Director.

2. From the Director dialog that appears, choose the Director’s 
address of the Media Controller you are setting up and choose 
Connect.
30 Composer Media Edition User Guide
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Exit Composer
To exit Composer:

From the Composer Startup screen, choose Exit Composer 
From menu bar, choose File > Exit.

Export Media List
To export the Media List:

1. Highlight the device that you want to export the Media List.

Example: Digital Audio

2. From the Media menu, select Export Media List.
This saves a copy of the file that contains all the title art and 
information from the Media Database to your PC. This option does 
move the actual media files.

Import Media List
To import the Media List from the PC to Media Database:

1. Highlight the device that you want to import the Media List.

Example: Digital Audio

2. From the Media menu, select Import Media List.
This saves a copy of the file that contains all the title art and 
information from your PC to the Media Database. This option does 
not move the actual media files.
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Search Topic
To search documentation:

1. Select Help > Search tab.

2. Enter a topic you want to find.

3. Press Enter.
4. Choose from the available entries.

Update Composer Media Edition from Help Menu
To update Composer from the Help menu:

1. From the Help menu, select Check for Updates.

2. Follow the online instructions to complete the update.

Update Composer Media Edition from Windows Start 
Menu

To update Composer from Windows Start Menu:

1. Select Start > All Programs > Control4 > Composer > Update 
Composer.

2. Follow the online instructions to complete the update.

Update Composer Media Edition by Running 
Installation

To update Composer from the installation:

1. Run the installation.

2. Follow the online instructions to complete the update.
32 Composer Media Edition User Guide
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View Index
To access documentation index:

1. Select Help > Index tab.

2. View the available topics and subtopics.

3. Choose from the available entries by double-clicking an entry to 
view the topic or a list of subtopics.
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C h a p t e r 4 Introduction to Composer Media 
Edition Software

The Composer Media Edition interface allows you to add and scan 
media to your controller hardware, such as Media Controller. 

You can also create 
playlists of MP3 
files saved on the 
controller 
hardware’s hard 
drive in the Media 
Database.

Adding or scanning 
media allows you to 
view and select the 
stored/ broadcast 
media and playlists 
from the Navigator 
devices, including 
Wireless Touch 
Screen, On-screen, 
Mini Touch Screen, 
and System 
Remote Control.

Topics covered in this chapter:

“Composer Media Edition Startup”

“Directors Dialog” on page 37

“Media View” on page 38

“Menu Bar” on page 39
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Composer Media Edition Startup
From the Composer Media Edition Startup 
Screen, you can connect to controller 
hardware locally (center option). 

The Composer Media Edition does not provide 
the Virtual (left option) or Remote Director 
(right option) options. 

Startup Screen Director on Local Network. Allows you to manage media while 
connected to a Director on your home network. Launches the Directors 
dialog. For more information, see “Directors Dialog” on page 37. 
Exit Composer. Allows you to exit Composer and return to the desktop. 
When you exit, Composer prompts you to back up your project to your PC 
hard drive.

Related Tasks:
“Connect to Director on Local Network” on page 30
“Exit Composer” on page 31
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Directors Dialog
This Directors dialog appears when you click the Connect to a 
Local Director from the Startup screen.

Connecting to a Director on the home network allows you to set up 
your media on your controller hardware so it is viewable on the 
Navigator devices, such as Wireless Touch Screen, On-screen, 
and Mini Touch Screen. 

Each Director has an associated address.

Directors 
dialog

Connect. Allows you to connect to the Director that resides on controller 
hardware on the home network.
Cancel. Cancels and closes the Director dialog box.
Add. Launches a dialog that allows you to add the Director’s address of 
the controller hardware you are trying to connect. 
Refresh. Allows you to update the Director list to display recently added 
Directors.

Related Tasks:
“Connect to Director on Local Network” on page 30
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Media View
The Media view allows you to 
add to the system your media 
selections, including stored 
music and media collections 
or broadcasts channels and 
stations.

Adding media in Composer 
Media Edition allows you to 
view and select the stored or 
broadcast media from the 
Navigator devices, including 
Wireless Touch Screen, On-
screen, Mini Touch Screen, 
and System Remote Controll.

Media View
(left-side 
selections 
change right-side 
view)

There are two types of media in the system:

Stored Media. Includes the possible media types:
CD. Allows you to store CD selections by viewing jacket art, album, 
artist, and genre type (such as rock or country).
DVD or Disc Changer. Allows you to store DVD and CD selections by 
viewing jacket art, title, info, results, media, and disc list.
MP3 on Digital Audio Player. Allows you to store MP3 — HDD Music 
selections by viewing jacket art, album, artist, and genre type (such as 
rock or country).

Broadcast Media. Includes the possible media types:
Direct TV. Allows you view Direct TV channel options including Station 
ID, Genre, and Music Channel.
Dish Network. Allows you view Dish Network channel options 
including Station ID, Genre, Rating, and Music Channel.
Cable TV. Allows you to view Cable channel options, including Station 
ID, Genre, Rating, Music Channel.
UHF/VHF. Allows you to view the UHF channel options including 
Station ID, Genre, Rating, HDTV.
AM/FM/XM. Allows you to scan AM, FM, and XM stations.
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Menu Bar

Media View — 
continued
(left-side 
selections 
changer right-
side view)

Media View Related Tasks
“Now that you have completed “Set up Media” continue to “Test System by 
Playing Media on Navigator Device” on page 131.” on page 23
“Set up Media on DISC Changer” on page 9
“Set up Media for Broadcast Television Channels” on page 15
“Set up Media for Broadcast Stations” on page 17
“Create Playlist” on page 21
“Refresh Navigators” on page 23

Menus The Menu bar provides the following menus:

File menu — Use to connect to the Director on your home network, 
refresh Navigator devices with new media information, and exit 
Composer Media Edition. 
Media menu — Use to create new playlist. Also, use to clear, export, and 
import media lists. See “Media Menu” on page 41.
Help menu — Use to view on-line help and versioning information. See 
“Help Menu” on page 42.
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File Menu
From the File menu, you can connect or disconnect from a Director, 
refresh Composer and Navigator devices, including Wireless Touch 
Screen, On-Screen, and Mini Touch Screen. You can also exit 
Composer. 

File Menu Connect to Director. Connects you to a Director residing on the controller 
hardware. When you connect, project configuration information from the 
controller hardware is presented to the screen in Composer. 
Disconnect from Director. Disconnects you from a Director. It prompts 
you to back up your project before disconnecting you from the currently 
connected Director. This option is available when connected to a Director. 
Refresh. Refreshes the Composer Media Edition screen with the current 
information from Director.
Refresh Navigators. Refreshes the Navigator devices with the latest 
information from Director. Some navigator devices include Wireless Mini 
Touch Screen, On-screen, Mini Touch Screen, and System Remote 
Control.
Exit. Exits Composer. It prompts you to backup the project, prior to exiting 
the software and returning to the desktop. 

File Menu Related Tasks:
“Launch Composer Media Edition Software” on page 4
“Connect to Director on Local Network” on page 30
“Refresh Navigators” on page 23
“Exit Composer” on page 31
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Media Menu
From the Media menu, you can create new playlists. 

Also, you can use the Media menu to clear, export, and import media 
lists. Media List is the list of media information pertaining to the selected 
device, such as all DVDs with associated cover art, title, notes, etc. for 
each DVD in a DVD changer. 

The media has either been scanned or manually added into the Media 
Database. After an item is added to the Media Database, the cover art 
and information about the media is viewable and selectable from any of 
the navigation devices, such as Mini Touch Screen, Wireless Touch 
Screen, On-Screen (viewable from TV monitor), etc.

TIP: It is recommended that you use the Export Media List feature so 
that you have a list of all your media saved to the hard drive of your PC.

Media Menu Clear Media List. Clears the media list of the highlighted device from the 
Media Database. 
Import Media List. Imports a media list from the PC to the controller 
hardware, such as Media Controller. 
Export Media List. Exports a media list for selected device from the 
controller hardware (such as Media Controller) to your PC.
Create Playlist. Allows you to create a playlist of MP3 files. The playlist 
will be available from any navigator device, such as Wireless Touch 
Screen, On-screen, and Mini Touch Screen. You can create playlist of any 
MP3 files that reside on the controller hardware, such as Media Controller. 
You can add albums, remove songs, reorder songs, etc. If you remove 
songs from a playlist, it does not remove it from the Media Database.
Delete Playlist. Allows you to remove a playlist.

Media Menu Related Tasks:
“Clear Media List” on page 29
“Import Media List” on page 31
“Export Media List” on page 31
“Create Playlist” on page 21
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Help Menu
From the Help menu, you can access the on-line documentation 
version of this manual with index and search options. 

You can also check for updates and check the version of your 
Composer software and Director component.

.

Help Menu From the Help Menu, you have the following options:

Contents. Displays the Content tab of the User Help. 
Index. Displays the Index tab of the User Help.
Check for Updates. Takes you to the web update service allowing you 
to update Composer software and the associated drivers.
About Composer. Displays the Composer, Director, and Media Manager 
version information.

Related Tasks:
“Update Composer Media Edition from Help Menu” on page 32
“Search Topic” on page 32
“View Index” on page 33
42 Composer Media Edition User Guide

cember 20, 2005 Composer Media Edition 1.2.3 Release Control4 1.02



Index

A
Add an Audio or Audio/Video Switch to Control4 

System 20
Add and search using New DVD or New CD options 12
Auto Scan Enabled 15
Autoscan Media Within Composer 14

Autoscan Added Media 15
A-Z Tasks

Add and search using New DVD or New CD options 
12

Autoscan Media Within Composer 14
Channels 15
Create Playlist 21
Refresh Navigators 23
Scan media on DISC Changer to Media Database 

10
Search media on DISC Changer to add to Media 

Database 10
Set up Media for Broadcast Stations 17
Set up Media on Digital Audio Player 7
Set up Media on DISC Changer 9

B
Broadcast Stations Set up 17
Broadcast Television Channels Set up 15

C
Composer 35
Composer software, defined 1
Composer Startup Screen 36
Connect to a Local Director 30
Create Playlist 21

D
Directors dialog 37

E
Exit Composer 31

F
File menu

definition 39
description 40

H
Help menu

definition 39
description 42

I
Interface

Set up Media on Digital Audio Player 7
interface

Composer Startup Screen
description 36

Composer, main interface 35
Directors dialog

description 37
File menu

definition 39
File menu, description 40
Help menu

definition 39
Help menu, description 42
Media menu

definition 39
Media menu, description 41
Media view

description 38
Menu bar

description 39

M
Media

setup tutorial 7
Media menu

definition 39
description 41

Media view
description 38

Menu bar
description 39

N
Navigator Refresh 23

P
Playlist Creation 21
 Index 43



R
Refresh Navigators 23

S
Scan media on DISC Changer to Media Database 10
Search media on DISC Changer to add to Media 

Database 10
Set up Media for Broadcast Stations 17
Set up Media for Broadcast Television Channels 15
Set up Media on Digital Audio Player 7
Set up Media on DISC Changer

description 9
New DVD or CD 9
Scan 9
Search 9

T
Task

Connect to a Local Director 30
Exit Composer 31

tutorials
Media Setup Tutorial 7
Navigator User Interface Setup Tutorial 7

U
User interface

setup tutorial 7

V
Version 1.2.1

Highlighted
Autoscan Media Within Composer 14

Version 1.2.3 20
 44 Composer Media Edition User Guide


	Get Started
	Software and Network Requirements
	Install Composer Media Edition Software
	Launch Composer Media Edition Software

	Set up Media and Playlists
	Set up Media on a Controller
	Set up Media on DISC Changer
	Autoscan Media Within Composer
	Set up Media for Broadcast Television Channels
	Set up Media for Broadcast Stations
	Use External Storage Devices
	Add an Audio or Audio/Video Switch to Control4 System
	Create Playlist
	Refresh Navigators
	Edit Media Information within Composer

	Other Composer Tasks
	Clear Media List
	Connect to Director on Local Network
	Exit Composer
	Export Media List
	Import Media List
	Search Topic
	Update Composer Media Edition from Help Menu
	Update Composer Media Edition from Windows Start Menu
	Update Composer Media Edition by Running Installation
	View Index

	Introduction to Composer Media Edition Software
	Composer Media Edition Startup
	Directors Dialog
	Media View
	Menu Bar
	File Menu
	Media Menu
	Help Menu



